Algunos usuarios, entre los que me incluyo, hemos tenido problemas con la última actualización de la Play Store de Google (3.10.9) debido a que tras la actualización, por causas desconocidas, la aplicación no marcaba como instaladas algunas de las aplicaciones, pese a estar disponibles en el dispositivo y funcionar sin ningún tipo de problema.

De hecho, el problema era tal que muchas de las aplicaciones eran marcadas como incompatibles, lo que impedía que volvieran a instalarse incluso desde la versión web de la tienda.

Tras varias pruebas, hemos conseguido dar con el origen del problema que, en nuestro caso, se debía a que habíamos modificado la densidad de la pantalla mediante la instalación de la ROM Paranoid, que como sabréis permite visualizar las aplicaciones en formato tablet.

Captura del market

En todo caso, la solución al problema, que obviamente permite seguir usando esta excelente ROM, es la siguiente:

  1. En la configuración del dispositivo, acceder a la pantalla de aplicaciones y seleccionar la vista que las muestra todas (tanto las aplicaciones de sistema como las de usuario), y proceder a seleccionar las vistas correspondientes a la tienda de Google (Google Play Store) y el framework de Android (Marco de servicios de Google), procediendo posteriormente a forzar la detención y borrar los datos de ambas aplicaciones.
  2. Seguidamente reiniciaremos el dispositivo en modo recovery y procederemos a borrar los datos de la partición de cache y de la dalvik-cache, tras lo que reiniciaremos el dispositivo.

Cómo solucionar los problemas de incompatibilidad del market

Este reinicio será significativamente más largo de lo habitual, ya que el sistema debe rehacer varios ficheros del sistema, pero una vez que éste arranque totalmente podremos acceder de nuevo a la tienda de Google y recuperar nuestra lista de aplicaciones.

Aunque también puede ser que no hayas sufrido este problema pero que algunas aplicaciones no se te muestren, bien porque el desarrollador no ha creído conveniente ofrecerlas en tu país o bien porque sencillamente no están disponibles para la resolución de tu dispositivo.

En ambos casos el problema tiene solución, ya sea mediante la instalación de una aplicación como Market Enabler, que permite engañar a Google y hacerle creer que nos encontramos en un país diferente o mediante la simple modificación del modelo de teléfono (atributos ro.product.model y ro.product.manufacturer) en el archivo /system/build.prop, aunque para ellos deberás rootear antes tu terminal.




Ingeniero en Informática por la Universidad Politécnica de Cataluña.Programador en perl, php, c++, Java,...Desarrollador reconocido del foro XDA-Developers.Usuario Android desde 2009, y actualmente también desarrollador de utilidades y ROMs para ese sistema.Mi primer smartphone fue un Qtek-S100, en 2005, y desde entonces ando buscando el dispositivo perfecto. Si no fuera por la crisis cambiaría de móvil varias veces al día :)

8 comentarios

  1. amigo actualice a jelly bean mi galaxy S I9000, tengo el problema de incompatibiliidad con las aplicaciones del google play store, hice lo que nos sugieres en tu post y no ha dado resultados. sobre lo ultimo que hay que hacer como editamos el archivo??? el sistema me pide completar, no se como hacer los cambios que dices???
    espero y agradezco tu respuesta

  2. Hola,
    Lo copias a la SD con un administrador de archivos como RootExplorer, después lo editas en el PC y finalmente lo vuelves a colocar en su sitio con RootExplorer 🙂

  3. hola amigo tengo un galaxy ace gt-s5830m lo tengo actualizado con jellybean 4.2.2 pero alguna aplicaciones me dicen que no son compatibles con el distpositivo y al tratar de hacer lo que explicas solo me sale la opcion de wipe cache pero la de dalvik cache no me aparece

Deja una respuesta