Las versiones de Android se suceden con el tiempo a un ritmo bastante constante y superior al que muchos de nosotros renovamos nuestros terminales. Incluso a una velocidad superior a la que los fabricantes actualizan sus dispositivos. Ocurre también que por motivos de hardware o comerciales, hay tanto smartphones como tablets en el mercado que ni salen con la última versión ni llegan a actualizarse a la misma. Esto no quiere decir que no funcionen ni que se conviertan en dispositivos inútiles que no merezcan ser comprados. Vamos a daros ahora nuestra opinión sobre qué versión de Android, como mínimo, debería tener nuestro próximo smartphone. No hace falta que sea Lollipop, aunque sí que sea KitKat. Os daremos algunas razones de peso y otras algo subjetivas, y vosotros tendréis que decidir. Pero al menos dedicad unos minutos a haceros una idea de si ese móvil que os gusta tanto merece o no la pena.

¿Qué versión de Android debe tener mi próximo móvil como mínimo?

Android evoluciona pero el salto entre versiones no siempre es tan grande como para que sea imprescindible tenerla para disfrutar de una gran parte de sus ventajas. O al menos para tener limitaciones de las que podamos darnos cuenta. El paquete de API de Android crece con el tiempo y cada ciertas versiones aparecen algunas bastante importantes, como en su momento ocurrió con el salto gráfico entre HoneyComb y Ice Cream Sandwich, o la llegada de Jelly Bean. Lollipop es una versión tentadora pero la que deberíamos tener de forma necesaria es Android 4.4 KitKat. Sí, no tiene mucha antigüedad y puede dejar fuera a muchos terminales que hayáis visto ya pero os explicamos por qué.

Con Android 4.3 JellyBean nos garantizamos el acceso al paquete de API que se incluyó en Android 4.1 y que incluía, entre otros servicios adheridos al sistema, Google Now. El asistente pasivo de Google ha sido muy importante desde su lanzamiento y cualquier versión posterior a la 4.1 lo lleva en su interior. Ha ido evolucionando pero sus mejoras han llegado a versiones anteriores así que lo que realmente importa es tenerlo, nada más. Esto haría que Android 4.3 fuese verdaderamente el mínimo a comprar, pero hay más.

¿Qué versión de Android debe tener mi próximo móvil como mínimo?

Android Wear. Nuestros queridos relojes inteligentes necesitan que el sistema sea compatible con Bluetooth 4.0 LE o Bluetooth de baja energía, un protocolo que permite consumir mucha menos batería y que supone la barrera de acceso a Android Wear. Si tenemos pensado tener uno de estos accesorios en un futuro no muy lejano necesitaremos un smartphone o tablet que disponga de Bluetooth 4.0 BLE y, por supuesto, que el sistema operativo lo soporte. Todo hace indicar que Android 4.3 Jelly Bean seguirá siendo la barrera de entrada a Android Wear durante mucho tiempo pero todo puede cambiar.

En cuanto a las aplicaciones, la gran mayoría de las mejores aplicaciones de Android funcionan a partir de Ice Cream Sandwich, algunas requieren Jelly Bean y unas pocas ya empiezan a pedir KitKat para funcionalidades como el modo inmersivo. ¿Por qué necesitamos entonces KitKat? Pues por algo muy importante que debemos tener en cuenta.

ART

Estas siglas son las que dan nombre a la nueva máquina virtual de Android, Android RunTime. En KitKat podemos seleccionarla en lugar de Dalvik, desde el modo de desarrollador, y pese a que en KitKat estaba en pruebas, en Lollipop ya llega como máquina exclusiva. Esto hará que las aplicaciones que se mantengan en Google Play comiencen a soportar ART de forma obligatoria, algo que puede hacer, porque la evolución es así, que lleguen a dejar de soportar Dalvik. Es poco probable pero existe esa posibilidad. No olvidemos que el año que viene llegará Android 6.0 y el siguiente 7.0 y así (son ejemplos) y que Dalvik será historia dentro de no demasiado. Así que igual que algunas aplicaciones dejaron de soportar Android 1.6 otras dejarán de soportar Android 4.3 y anteriores. Es así de sencillo, será un antes y un después de Android en muchos sentidos.

¿Qué versión de Android debe tener mi próximo móvil como mínimo?

Así que si vamos cortos de presupuesto podemos echar mano de un smartphone con Android 4.3 Jelly Bean y no deberíamos tener problemas pronto pero si el móvil en cuestión va a estar bastante tiempo en nuestro bolsillo, es preferible tirar de KitKat. Además, MediaTek, el principal fabricante de procesadores para smartphones de bajo coste, empieza a soportar KitKat en muchos de sus modelos por lo que las actualizaciones deberían llegar en unos meses para casi todos. Eso si el fabricante no ha abandonado el modelo, claro está. Cuidado con lo que compráis.

1 comentario

  1. Desvraciadamente para mi tengo un ZTE Grand X con la version android 4.04. Por que mi presupuesto de pensionado no da para mas, que me recomiendan ustedes al respecto? Cualquier repuesta se la agradeceria.

Deja una respuesta